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Another RMI service call is currently active Errors

Table of Content

Introduction

The error message "Another RMI service call is currently active error" is possibly just a subsequent error of a non reacting/hanging/not responding Adobe InDesign Server process.

Symptoms

  • InDesignServer.exe increases it's memory usage over time (related to load) and sometimes hangs

  • InDesignServer.exe hangs if there are fonts used within the InDesign documents which aren't installed on the InDesignServer directory

  • InDesignServer.exe crashes

  • Subsequent error messages like "Another RMI service call is currently active" found in censhare-Server Log, censhare-Client GUI or log or in the censhare-WebClient

Possible causes

  • Defect or corrupt InDesign documents

  • A script executed on an InDesign document during the render process leaving the InDesignServer in a hanging state.

  • Converted InDesign documents (for example from CS4 to CS5.5,which can be seen from the document history)

  • Too high load on InDesignServer.exe instances (for example too much PDF generations, too big documents which increases the memory persistent)

  • Not using the latest Adobe InDesign Server Rapid Release

  • Using censhare-Render Client and Server below versions 4.10.17, 5.1.9, 5.2.7, 5.3.7, 5.4.0

Workaround

  • Manually restart the Adobe InDesign Server Instances regularly if the memory usage increases (see Windows Task-Manager)

  • Use the censhare Render-Client auto-start feature to control Adobe InDesign Server and restart the InDesign Server Instances automatically (for example based on time, amount of errors or amount of performed jobs).

Troubleshooting & Root Cause Fixing

  • Ensure that the latest Adobe Rapid Release is installed

  • Ensure that the latest censhare-Server and Render-Client is installed

  • Check within the C:\Users\<user>\censhare\v4\render-client-0.0.log if always the same asset-id processed before the error message "Another RMI service call is currently active" appears

  • Analyse/repair the document in question (e.g. check document history if it is a converted one and create it from scratch)

  • Check used InDesign scripts in local InDesign and fix them.
    Hint: Sometimes even InDesign and InDesign server show a different behaviour


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